import re
regex = re.compile(r"(\w+\/\w+\.xml)(?![\s\S]*\1)", flags=re.MULTILINE)
test_str = ("my_folder/foo.xml::someextracontent\n"
"my_folder/foo.xml::someextracontent\n"
"another_folder/foo.xml::someextracontent\n"
"my_folder/bar.xml::someextracontent\n"
"my_folder/bar.xml::someextracontent\n"
"my_folder/hello.xml::someextracontent")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")