re = /(\my_folder\/\w+\.xml)(?![\s\S]*\1)/m
str = 'my_folder/foo.xml::someextracontent
my_folder/foo.xml::someextracontent
another_folder/foo.xml::someextracontent
my_folder/bar.xml::someextracontent
my_folder/bar.xml::someextracontent
my_folder/hello.xml::someextracontent'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end