using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"c:(?<category_name>(?:"")(?!\d+)[^""]+(?:"")|(?!\d+)[^ ]+)";
string input = @"python c:192 c:1Stackoverflow c:""Stack Overflow2""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}