$re = '/(COM-)(ALM\d+_)(BIT\D.+)/m';
$str = '"COM-ALM11_BIT10"
"COM-ALM2_BIT10"
"COM-ALM1_BITcodiert"
"COM-ALM2_BITmummer10"
"COM-CMD_Request"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);