import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+?(?:00)?(?:49|\\(49\\))|\\(\\+49\\))(?: *\\(\\d{4}\\)|(?: ?\\d){4})? *\\d\\d(?:[ -]?\\d\\d){2}$";
final String string = "+491739341284\n"
+ "+49 1739341284\n"
+ "(+49) 1739341284\n"
+ "+49 17 39 34 12 84\n"
+ "+49 (1739) 34 12 84\n"
+ "+(49) (1739) 34 12 84\n"
+ "+49 (1739) 34-12-84\n"
+ "0049 (1739) 34-12-84";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}