package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*dm.*`)
var str = `vcvcvdfvc
fddhfghfdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}