re = /\bV\S+\.00\b/m
str = 'Hello match this C90.083635. 11 character long word not C90.083635.73G because it exceed 11 character and not C90.08363 because is not 11 character long.
test VT500.00 test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end