// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?1.{0,5}2.*|^.*?23.*").unwrap();
let string = "1.....23
1.....21
23......
12.....1
1...2...
....23..
213....2
1......2
213....3
2.....21";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}