$re = '/(?=.{0,3}\/\/.{0,100}[a-zA-Z0-9])(?=\S+$).{2,5000}/m';
$str = 'ssdfsdfsdfasdfasdfasdfdfd//yH5BAEkjfsdafdfsafasdfas
http//yH5BAEkjfsdafdfsafasdfas
ssdfsdfsdfasdfasdfasdfdfd//yH5B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);