$re = '/(ISBN: )([0-9]{3})-([0-9]{10})/';
$str = 'ISBN: 978-0226143675';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);