$re = '/\s*(?P<command>.*?)/[/*](?P<optional>.*)/m';
$str = 'say hi /* comment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);