$re = '/^((?!.\.)([A-Za-z\d]+[\-_])*[A-Za-z\d]+\.)*(?:testnet|near)$/m';
$str = '// VALID
example.near
example.testnet
sub.xtrtarstsrt3322.testnet
1sub.sub.near
12.near
aa.testnet
1a.a3a.near
deltron-me.testnet
deltron_yes.near
Fmish.testnet
shanty-d.testnet
// INVALID
aa.setetstestnet
_sentaent.testnet
_sentaent-.testnet
sentaent-.testnet
me__sentaent.testnet
me_-taernst.testnet
-howabout.this.near
space should fail.testnet
space should fail.near
!testnet.testnet
2a!.near
n.testnet
shouldnotendwithperiod.testnet.
aa.t.testnet
1a..near
touchingDotsShouldfail..testnet
.aa.testnet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);