import re
regex = re.compile(r"[_](\d{1,4})[.]", flags=re.MULTILINE)
test_str = ("1234test.mp3\n"
"999test.mp3\n"
"12test.mp3\n"
"0test.mp3\n"
"0test.mp34\n"
"test1234.mp3\n"
"@test.mp3\n"
"/test.mp3\n"
"\\\\test.mp3\n"
"test_1.mp3\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")