$re = '/(?<=black) (\w+)/m';
$str = 'black pen
black pencil
red pen
red crayon
purple crayon
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);