package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s|^)\b`)
var str = `The quick brown fox jumped over the lazy dog.
The lazy dog ignored the fox and went back to sleep.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}