$re = '/{([\p{L}\-_]+)}/';
$str = '{Изберете_цвят}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);