$re = '/(?<!@)@[^\s@]\S*/m';
$str = 'Stuff @relRef more stuff @@absRef
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);