import re
regex = re.compile(r"(?<=^|\s)(?:(\w*')?)(@(\S+))", flags=re.MULTILINE)
test_str = ("1. take this -> @Mark\n"
"2. take this -> @mark_2\n"
"3. take this -> @中国\n"
"4. take this -> l'@antro\n"
"5. don't take this -> 中国@中国.zh\n"
"6. don't take this -> 中国@google.zh\n"
"7. don't take this -> info@google.com\n"
"8. don't take this -> 99@test.com\n"
"9. take this -> dell'@altro")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")