#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\1\1|^.)+.$"
Local $sString = "x" & @CRLF & _
"xx" & @CRLF & _
"xxx" & @CRLF & _
"xxxx" & @CRLF & _
"xxxxxxxx" & @CRLF & _
"xxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"aa" & @CRLF & _
"aaa" & @CRLF & _
"aaaa" & @CRLF & _
"aaaaa" & @CRLF & _
"aaaaaa" & @CRLF & _
"aaaaaaa" & @CRLF & _
"aaaaaaaa" & @CRLF & _
"aaaaaaaaa" & @CRLF & _
"aaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")