$re = '/^([0-1][0-9]|2[0-3]):00$/m';
$str = '--> Valid values
00:00
01:00
02:00
03:00
04:00
05:00
06:00
07:00
08:00
09:00
10:00
11:00
12:00
13:00
14:00
15:00
16:00
17:00
18:00
19:00
20:00
21:00
22:00
23:00
--> Invalid values
10
02:30
10:20
21:40
001:00
24:00
:00
1:00
0:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);