#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:ALARM[\s]*)(?:\d*)[A-Za-z\s\d\.=]*(?:Alarm\sraised\stime)\s+=\s+([\d\-]+\s[\d\:]+)\s+(?:Location\sinfo)\s+=\s+Local\sCell\sID=([\d]+)(?:,\s[a-zA-Z]+\s[A-Z]+\s[A-Z]+\s[a-zA-Z\=,]+\s[a-zA-Z\=-]+\s[a-zA-Z\=-]+\s[a-zA-Z\=-_,]+)[\s\,A-Za-z0-9=\_]*(?:eNodeB\sID=)([0-9]+)(?:,.+\s\s+.+\s+)(?:Cleared\stype)\s+=\s+([a-zA-Z ]+)(?:[\sA-Za-z\s=]*)([\d-]*\s[\d:]+)"
Local $sString = "L_SAMBIL" & @CRLF & _
"+++ L_SAMBIL 2020-09-21 11:53:53" & @CRLF & _
"O&M #1502" & @CRLF & _
"%%/*1882154167*/LST ALMLOG:ALMTP=all,CLRFLG=cleared-1&uncleared-1,CLRSD=2020&09&21,CLRED=2020&09&22,STARTAID=29240,ENDAID=29240;%%" & @CRLF & _
"RETCODE = 0 Operation succeeded" & @CRLF & _
"" & @CRLF & _
"ALARM 72712 Fault Major eNodeB 29240 Signaling " & @CRLF & _
" Sync serial No. = 162656" & @CRLF & _
" Alarm name = Cell Unavailable" & @CRLF & _
" Alarm raised time = 2020-09-21 06:36:19" & @CRLF & _
" Location info = Local Cell ID=2, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL2, eNodeB ID=15080, Cell ID=2, Specific Problem=External link fault" & @CRLF & _
" Function = eNodeB Function Name=L_SAMBIL, objId=0" & @CRLF & _
" Cleared type = Normally cleared" & @CRLF & _
" Cleared time = 2020-09-21 06:39:42" & @CRLF & _
" Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL" & @CRLF & _
" Special info1 = AF_L=L_SAMBIL" & @CRLF & _
"" & @CRLF & _
"ALARM 72713 Fault Major eNodeB 29240 Signaling " & @CRLF & _
" Sync serial No. = 162655" & @CRLF & _
" Alarm name = Cell Unavailable" & @CRLF & _
" Alarm raised time = 2020-09-21 06:36:19" & @CRLF & _
" Location info = Local Cell ID=3, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL3, eNodeB ID=15080, Cell ID=3, Specific Problem=External link fault" & @CRLF & _
" Function = eNodeB Function Name=L_SAMBIL, objId=0" & @CRLF & _
" Cleared type = Normally cleared" & @CRLF & _
" Cleared time = 2020-09-21 06:39:41" & @CRLF & _
" Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL" & @CRLF & _
" Special info1 = AF_L=L_SAMBIL" & @CRLF & _
"" & @CRLF & _
"ALARM 72711 Fault Major eNodeB 29240 Signaling " & @CRLF & _
" Sync serial No. = 162654" & @CRLF & _
" Alarm name = Cell Unavailable" & @CRLF & _
" Alarm raised time = 2020-09-21 06:36:19" & @CRLF & _
" Location info = Local Cell ID=1, Cell FDD TDD indication=FDD, NB-IoT Cell Flag=FALSE, Cell Name=L_SAMBIL1, eNodeB ID=15080, Cell ID=1, Specific Problem=External link fault" & @CRLF & _
" Function = eNodeB Function Name=L_SAMBIL, objId=0" & @CRLF & _
" Cleared type = Normally cleared" & @CRLF & _
" Cleared time = 2020-09-21 06:39:41" & @CRLF & _
" Special info = RAT_INFO=L, AFFECTED_RAT=L, DID=NULL" & @CRLF & _
" Special info1 = AF_L=L_SAMBIL" & @CRLF & _
"(Number of results = 3)" & @CRLF & _
"" & @CRLF & _
"--- END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")