$re = '/(?:
\G (?!\A) \N*?
|
\A .*?
) \K text2/xs';
$str = 'text3 text3 text3 text3 text3 text3
text1 text2 text1 text2 text1 text2
text1 text2 text1 text2 text1 text2
text1 text2 text1 text2 text1 text2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);