using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^( |\t)*(\w+)\1*::\1*\2\{\1*}";
string substitution = @"$2::$2()";
string input = @"TropicalFruitTOutput::TropicalFruitTOutput{}
: dad::CRunnable{}
, m_watermelon_out{}
#if MAX_FRUITS == (10)
, m_cherry_out{}
#endif
{
}
NationalFruitInput::NationalFruitInput{}
, m_banana_in{}
, m_dragronFruit{PAD_GetdragronFruitPAD_B(xcxcxc)}
{
}
SpecialFruits::SpecialFruits{}
: AmazingClassType{}
, m_kiwi{}
, m_avocado{ // PRQA S 2961 # FALSEPOSITIVE QAC warning about uninitialized
// Hello world
// This is just a comment for
// testing purpose
m_apricotController.getApricotList()}
{
}
using NewFruitsBase::NewFruitsBase;
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}