$re = '/\d+/m';
$str = 'WN (Hoàn thành) - 11: Đệ tử và Goblin (End)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);