$re = '~^[\d\p{L}\h]{3,25}$~';
$str = 'محمد125 hasan ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);