import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "input..*(?<=name=['|\"])([\\w]+)['|\"]";
final String string = "<form method=\"post\" action=\"guardar.php\">\n"
+ " <input type=\"hidden\" name=\"produto1\" value=\"teste1\">\n"
+ " <input type=\"hidden\" name='produto2' value=\"teste2\">\n"
+ " <input type=\"hidden\" name=\"produto3\" value=\"teste3\">\n"
+ " <input type=\"hidden\" name='produto4' value=\"teste4\">\n"
+ " <input type=\"hidden\" name=\"produto5\" value=\"teste5\">\n"
+ "<input type=\"submit\" value=\"enviar\">\n"
+ "</form>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}