package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^().]*\([^)]*\)[^().]*`)
var str = `Tom (Ed.) went down to the shop where the owners (J. Guys, A. Owner, and B. Ains) gathered. It was a great night.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}