$re = '/.*?(?:row|):([0-9]{1,})?;.*field:([0-9]{1,});.*name:([0-9]{1,})/m';
$str = 'row:1;field:2;name:3
:5;field:2;name:3';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;