package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bword=`)
var str = `,word=n word=, _word= 1word=, (word=)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}