$re = '/(?<!#)\b[^\W\d]*\d\w*/m';
$str = 'happening bit mediacon #2022ppopcon wearing stell naman today #sb19official 123 because h3llo also12 or 23old
!test1#test!test1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);