using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(?<controlador>\w*)(\/?)(?<accion>\w*)";
string input = @"/hola/pepe?variableGet=aslkdj";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}