package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`!profile|!adverse`)
var str = `5401b864ad2f1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}