$re = '/content\/(\w+)\/(\w+)\/(\d+)\/([^\/]+[\w]+)\/?(\w+)?$/im';
$str = 'content/foo/B6128/8918/foo+bar+foo
content/foo/B6128/8918/foo+bar+foo/3098h309h343g3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);