using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"apple(?:(?!apple).)*cat";
string input = @"apple
apple
apple
cat";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}