import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!-{3,}|content-).+$";
final String string = "------WebKitFormBoundaryKanSEkvcMamqayJY\n"
+ "Content-Disposition: form-data; name=\"fl\"; filename=\"emty\"\n"
+ "Content-Type: application/octet-stream\n\n"
+ "this is trial\n\n"
+ "------WebKitFormBoundaryKanSEkvcMamqayJY--";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}