package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(:?.0)?`)
var str = `12339.0
133339
159.0
dfkkei
something
32439`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}