$re = '/(:[A-z]\w+)(?!.*\1)/';
$str = 'test :one
:one test :one test :two';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);