$re = '/ ((18|19|20)[0-9]{2})$/';
$str = 'Test 1990';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);