re = /^([A-Z]{6}[0-9LMNPQRSTUV]{2}[ABCDEHLMPRST]{1}[0-9LMNPQRSTUV]{2}[A-Z]{1}[0-9LMNPQRSTUV]{3}[A-Z]{1})$|([0-9]{11})$
/m
str = 'BRGCST76L27L219T'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end