re = /\b(?:[a-z]{3}\b)?+[a-z]+/
str = 'an of and then some an ee halved or or whenever'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end