const regex = /([A-Z ,\.\-\&#\\\\n\/0-9&]+)(\d{10})([A-Z a-z])(\d{1}-\d{7}-\d{3}-\d{4}|\d{1}-\d{7}-\d{2}-\d{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z ,\\.\\-\\&#\\\\\\\\n\\\/0-9&]+)(\\d{10})([A-Z a-z])(\\d{1}-\\d{7}-\\d{3}-\\d{4}|\\d{1}-\\d{7}-\\d{2}-\\d{4})', '')
const str = `\\nTHIS IS FIRST PATTERN 63101 0789158126 0-0000000-000-0000\\n4415 THIS IS FIRST \\nPATTERN 49401-9528\\n0406842931 Third match 0-0000000-000-0000\\n11403 THIS IS FIRST PATTERN 49401-\\n9595\\n0112853789 Third match 0-0000000-000-0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}