$re = '/^[A-Z]{6}[0-9]{2}[ABCDEHLMPRST]([0][1-9]|[1-6][0-9]|[7][0-1])[A-Z]$/m';
$str = '
Surname: MRT
Name: MTT
Birthdate and gender: 91D08
Place of birth: F205
Check digit: J
Fiscal code: MRTMTT91D08F205J
MRTMTT91D08F205J
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);