$re = '/[.]*[.]*([0-9$|\[\]\-\(\)]*)$/m';
$str = '1.3.6.1.4.(4|25|3[6-9])$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);