re = /(?<=^(?:\(|1 )?)\d{3}/m
str = '415-555-1234
650-555-2345
(416)555-3456
202 555 4567
4035555678
1 416 555 9292'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end