import Foundation
let pattern = #"((http|https)(\:\/\/)((([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16}))|(([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16})))((([\/a-zA-Z\ _\-%0-9\.\?\=]{1,3000})|(\/)|())))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://timmyrs.de"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}