#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(\w*)=\s?\d"
Local $sString = "#!/bin/bash" & @CRLF & _
"" & @CRLF & _
"flavor=${1:-dzen2}" & @CRLF & _
"" & @CRLF & _
"function gmail() {" & @CRLF & _
"while true" & @CRLF & _
"do" & @CRLF & _
" inbox_count=$(wget -q -O- --auth-no-challenge --user=something@gmail.com --password=something 'https://mail.goog$" & @CRLF & _
" echo "Gg:$inbox_count"" & @CRLF & _
" sleep 60" & @CRLF & _
"done" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"function weather() {" & @CRLF & _
"while true" & @CRLF & _
"do" & @CRLF & _
" weather_stat=$($HOME/.config/i3/./weather.sh)" & @CRLF & _
" echo "F$weather_stat"" & @CRLF & _
" sleep 900" & @CRLF & _
"done" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"function time_date() {" & @CRLF & _
"while true" & @CRLF & _
"do" & @CRLF & _
" klocka=$(date +'%A den %d %B v%V %H:%M')" & @CRLF & _
" echo "S$klocka"" & @CRLF & _
" sleep 10" & @CRLF & _
"done < <(echo)" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"bspc control --put-status" & @CRLF & _
"xtitle -sf "T%s" > "$PANEL_FIFO" &" & @CRLF & _
"weather > "$PANEL_FIFO" &" & @CRLF & _
"gmail > "$PANEL_FIFO" &" & @CRLF & _
"time_date > "$PANEL_FIFO" &" & @CRLF & _
"case "$flavor" in" & @CRLF & _
"bar)" & @CRLF & _
" cat "$PANEL_FIFO" | .config/bspwm/panel_bar | bar" & @CRLF & _
";;" & @CRLF & _
"dzen2)" & @CRLF & _
" . .config/bspwm/panel_colors" & @CRLF & _
" PANEL_HEIGHT=14" & @CRLF & _
" FONT_FAMILY='Dejavu Sans'" & @CRLF & _
" FONT_SIZE=9" & @CRLF & _
" cat "$PANEL_FIFO" | .config/bspwm/panel_dzen2 -f "$FONT_FAMILY" -s "$FONT_SIZE" | \" & @CRLF & _
" dzen2 -h $PANEL_HEIGHT -dock -ta l -title-name panel -fn "${FONT_FAMILY}:pixelsize=${FONT_SIZE}" \" & @CRLF & _
" -fg "$COLOR_FOREGROUND" -bg "$COLOR_BACKGROUND"" & @CRLF & _
";;" & @CRLF & _
"esac"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")