$re = '/[A-Za-z](\d+)[A-Za-z]
/m';
$str = 'A123R221343
A12323Q123213
L122F898';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);