const regex = /^https?:\/\/(((?!desktop).*\.)?(githubusercontent|githubstatus|github)\.(?!io|myshopify|blog|community)).*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(((?!desktop).*\\.)?(githubusercontent|githubstatus|github)\\.(?!io|myshopify|blog|community)).*', 'mg')
const str = `https://github.com/DarkThemeHub/GithubDarkTheme/
https://github.com/DarkThemeHub/
https://github.com/
https://pages.github.com/
https://raw.githubusercontent.com/DarkThemeHub/GithubDarkTheme/master/LICENCE
http://pages.github.com/
https://www.githubstatus.com/
https://developer.github.com/
https://help.github.com/en
https://support.github.com/
#should not match following
https://www.google.com/search?q=github&rlz=1C1PRFI_enGB877GB877&oq=github&aqs=chrome..69i57j69i60l6j69i65.1527j0j4&sourceid=chrome&ie=UTF-8
https://www.google.com/search?rlz=1C1PRFI_enGB877GB877&sxsrf=ACYBGNTdOnxT4FtUGQrGBdsLwdwP4vqYLQ%3A1578868177870&ei=0Z0bXs_gNOGGhbIProal0A8&q=github.com&oq=github.com&gs_l=psy-ab.3..35i39j0l9.103.358..1309...0.0..0.133.404.2j2......0....1..gws-wiz.......0i7i30.JWbDVwMFzHg&ved=0ahUKEwiPjY6njv_mAhVhQ0EAHS5DCfoQ4dUDCAs&uact=5
https://www.google.com/search?sxsrf=ACYBGNQ6mBQXfPi8Zuwm1WavyLIOTTNSKw%3A1578869437012&ei=vaIbXog91MHyAomUivgJ&q=github.com&oq=github.com&gs_l=psy-ab.3..35i39j0l9.1173.2046..2166...0.2..0.59.221.4......0....1..gws-wiz.......0i71j0i273.I-jQ27pFmlA&ved=0ahUKEwjIj8L_kv_mAhXUoFwKHQmKAp8Q4dUDCAs&uact=5
https://desktop.github.com/
https://github.myshopify.com/
https://sagioto.github.io/maven2gradle/
https://jspenguin2017.github.io/uBlockProtector/
https://www.howtogeek.com/180167/htg-explains-what-is-github-and-what-do-geeks-use-it-for/
https://twitter.com/github?something
https://serokell.io/blog/comparison-of-github-and-gitlab
https://github.community/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}