$re = '/(?=.*[0-9])(?=.*[A-Z])[0-9a-zA*]{5,}/m';
$str = 'e324FDfdffgdvs4Ddsfd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);