import re
regex = re.compile(r"(?<elIf>#elif\((?<elIfContents>[^\)]+)\)(?<elIfResult>[\s\S]+?(?=#elif|#end)))", flags=re.IGNORECASE)
test_str = ("Note: the #end should be added to the result of the ifelse group in part 1\n\n"
" #elif(#C.Length >= 1.9m)\n"
" Tall boi\n"
" #elif(#C.Name == bob)\n"
" Hi bob\n"
" #end\n\n"
"#elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob#end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")